Clutch Pedal won't go to floor after install.

  • Login or Register, members don't see Ads!
  • Tip: You can toggle the Dark Theme at the bottom of the page

1FastT2

Private
Dec 22, 2016
30
Long story short...

I just completed installing a new engine. The transmission stayed in the car while the engine was out. Clutch worked fine when engine was removed. Works now however will not travel to the floor the last inch or so. I imagine there's something not aligned properly. I've read about others having the same issue however there was never a follow up as to the fix.

Figured I'd post before I spend the day removing the transmission.
 

1FastT2

Private
Dec 22, 2016
30
For anyone that searches this topic after installing a new clutch I have the answer.

While I was in the process of building my engine for 6 months or so I must have accidentally pressed the clutch pedal in slightly while the transmission/slave cylinder was free from the clutch / pressure plate.

What this did was bleed more fluid in the slave cylinder then there was previously. When I then reattached the engine to the transmission the slave cylinder piston position was out further then it was before. This caused a false end travel to the slave cylinder.

Moral of the story, if you encounter this.. Do NOT press the clutch pedal further then it allows, you WILL blow out the slave cylinder. Instead just bleed the system and you will be back in business.

Hope this helps someone in the future.
 
  • 1Like
  • 1Informative
Reactions: AzNdevil and KevinC39

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top