N54 DCT w/M3 Conversion

derekgates

Sergeant
Feb 23, 2018
274
NW FL
what should be coded to allow a 3.15 LSD to work on a stock N54 DCT 335i?
This entire thread covers that...

You will need a GWS from an M3, final drive of +/- 10% of 3.15 ratio installed in the rear, following coding of Z0 and other items... then it will work. You have to trick the car/TCU into thinking it is an M3/M3 GTS for the drivetrain...
 
Last edited:
  • 1Like
Reactions: Begood69

Begood69

Specialist
Nov 13, 2016
89
Fayetteville, NC
I have a 335i 04/2007 AT.

Can someone help me with the wiring. I want to swap to m3 gts, i have an m3 gws not lighting, m3 szl not showing either on my protools, m3 dsc communicates (repinned the new sensor) but need to wire the dct switch, and the power to DME. Park should work, i repinned the wire that should b and to where they should connect. But no change yet. I assume due to gws not lighting up.

As i troubleshoot, i saw i am missing some wires on the blue connector 6031pin 3-4 From the original harness plugging into the dct tranny harness. All other wires i moved around and repined to match were they needed to be. Except those 2 i can t find where to get them from or where to go.
Thx
 

Begood69

Specialist
Nov 13, 2016
89
Fayetteville, NC
Finally got it working. Now i need the coding part. Also can someone confirm i def need the m3 speed sensors? Can i use after market ones, 335is or 335i from newer versions if i am using the M3DCS. Thx
 

Begood69

Specialist
Nov 13, 2016
89
Fayetteville, NC
I just have a tendency to define things as I think I run across them, but they obviously planned for or left the door open for a 1M DCT. I can't help not to wonder what hardware/coding might be needed to get it active on 335is or Z4is, but seems like it would have to be a lot less work than the M3 swap, maybe for a lot less benefit too, no idea.

Just a few I think are correct:

View attachment 27071
I just looked at my XDF and i dont see those parameters? Could u please help?.
 

RSL

Sergeant
Aug 11, 2017
445
I'll get the addresses tonight. I'm not sure the M3 and 1M buttons are routed/controlled the same for actually getting end functions working though. 1M at least seems to take the path of non-M modules/wiring.
 

Stokes

Corporal
Jan 26, 2018
170
Houston, TX
Ok, so I used a M3 ABS/DSC unit, reflashed it with my VIN, and by spoofing the VO coded it in. The M3 unit connects directly to the DSC button like a M3 would but the difference with the MDM function as it relates to a M3 is that it's also controlled in part by the M3 DME I believe. In a 1M the DSC goes through the JBBF as a non M 335i does. Now I'm pretty sure I could flash the 1M zb to the DSC, reroute back through the JBBF and have MDM as it relates to the 1M, I even have the IKMOS rom if it plays into it at all but it's just not worth the hassle.

The M3 software is already much looser than the non M software and I've already coded what I can to give me the even looser EU spec parameters. Even with DSC on the tires have no problem breaking loose and it only kicks in when it starts to get a little out of shape. I prefer the simple on or off rather than the intermediate step. With it off you can get full stupid, if that's what you want but with the LSD, sticky tires, and the suspension upgrades and M3 software it's very controllable. I'm enjoying the shit out of this car and setup, and I don't even have a M3 rack in it yet.
You wouldn't happen to have the ZUSB for the 1M, would you? Well, before that, how long did it take to swap the DSC? I've had a M3 DSC unit since this all started, but when I found out it had to be hard wired, I just left it on the shelf.

Looking up the owners manual, the 1M DSC works like the 335/135. So wondering if the hardware only different in sense of dual lines to the rear vs one and maybe higher rate solenoids? I'd like to try flashing it on my non-M dsc and see if it takes to test the electronics portion, but have forgotten how to look up the right ZUSB. Or do you set your VO to be a 1M and then use comfort mode to let it auto select the right one? Man, it's been a while.

Manual snap shot for your reading pleasure. It's funny some of the German to English translations.
 

Attachments

Stokes

Corporal
Jan 26, 2018
170
Houston, TX
Well I'm getting even closer to done! I'm definitely no seamstress so there's a fair chance I'll pay someone to redo the leather on the shift knob, but it looks decent enough for now... from a distance.
The shiftlogic button is literally just wedged in there with no connector on the backside and some wire wraps on the pins but it works lol
May try black hot glue or epoxy and then fine tune it into looking better, but not awful for now.
Looking good!

You're adaptation to the 135i plastic frame for the shifter boot looks like you did it way better than I did. Mine is a bit tight when I go to reverse and it pops the whole silver portion up from the side closer to the cup holder.... but only when it's really cold out. I was thinking about getting an leather boot from a manual car to redo mine. I like your shift logic button mount. I never got fancy, so mine still sits in from the top. lol
 

Attachments

Stokes

Corporal
Jan 26, 2018
170
Houston, TX
Finally got it working. Now i need the coding part. Also can someone confirm i def need the m3 speed sensors? Can i use after market ones, 335is or 335i from newer versions if i am using the M3DCS. Thx
As far as I recall, you do not need M3 specific speed sensors. I think that was some research going on trying to resolve the lazy shifting before we realized the limited tolerance of the gearing that the DCT software required.
 

Begood69

Specialist
Nov 13, 2016
89
Fayetteville, NC
As far as I recall, you do not need M3 specific speed sensors. I think that was some research going on trying to resolve the lazy shifting before we realized the limited tolerance of the gearing that the DCT software required.
Well with the m3dsc i am getting speedsensors code. And i still can t calibrate the sensors with the m3swl. Also i retaing a few errors and dont see m3gws and does not illuminate. 🤬
Also the power button (wired to 12 gray connector) and dsc_off wired to pin 41 dsc dont work. I have the grd on pon pnr of the x4444 connector and power on 4 and dsc on 6 . Do i need a pos in there or light power in any of those empty slots in that connector?
 

Attachments

Last edited:

Stokes

Corporal
Jan 26, 2018
170
Houston, TX
Well with the m3dsc i am getting speedsensors code. And i still can t calibrate the sensors with the m3swl. Also i retaing a few errors and dont see m3gws and does not illuminate. 🤬
Also the power button (wired to 12 gray connector) and dsc_off wired to pin 41 dsc dont work. I have the grd on pon pnr of the x4444 connector and power on 4 and dsc on 6 . Do i need a pos in there or light power in any of those empty slots in that connector?
I have yet to change my DSC unit. I do get a weird shadow code from the GWS about not getting a proper signal from the DSC, but don't seem to matter. Have you let ISTA-D (or Reingold or whatever it's called) try to resolve it? It offers diagnostic hints as well.
 
  • 1Like
Reactions: Begood69

Stokes

Corporal
Jan 26, 2018
170
Houston, TX
I found where the ZB# was posted for the 1M DSC.

 

Stokes

Corporal
Jan 26, 2018
170
Houston, TX
I have yet to change my DSC unit. I do get a weird shadow code from the GWS about not getting a proper signal from the DSC, but don't seem to matter. Have you let ISTA-D (or Reingold or whatever it's called) try to resolve it? It offers diagnostic hints as well.
Looks like it was confirmed... wheel speed sensors with the M3 DSC.
 
  • 1Love
Reactions: Begood69

azshantris

Private
Aug 27, 2019
47
Looking good!

You're adaptation to the 135i plastic frame for the shifter boot looks like you did it way better than I did. Mine is a bit tight when I go to reverse and it pops the whole silver portion up from the side closer to the cup holder.... but only when it's really cold out. I was thinking about getting an leather boot from a manual car to redo mine. I like your shift logic button mount. I never got fancy, so mine still sits in from the top. lol
Thanks 😁
I ended up using my 135i boot stitched to like 1/4 inch of the m3 shifter leather. I had the same issue with it popping up at first but I stretched the stiches out a bit and no problems now. I am however looking for a local upholsterer to redo it a bit more professionally for me cause you can definitely see my stitching.
I'm all in on the custom no reversing cutting. I've been using a dremel with sanding or grinding wheels and just hogging out plastic as necessary 😅
I might go one more pass with some sugru and then try sanding and repainting but it's gotten pretty good for now.
 
  • 1Like
Reactions: Begood69

Begood69

Specialist
Nov 13, 2016
89
Fayetteville, NC
I have yet to change my DSC unit. I do get a weird shadow code from the GWS about not getting a proper signal from the DSC, but don't seem to matter. Have you let ISTA-D (or Reingold or whatever it's called) try to resolve it? It offers diagnostic hints as well.
I will use istap today and see. Hope it works.

Looks like it was confirmed... wheel speed sensors with the M3 DSC.
Just ordered them on fcp. Thx for reconfirming

Should try jb weld plastic and have the hold perfect on and it is blk color. Then put the button. But it looks great already
 

RSL

Sergeant
Aug 11, 2017
445
I found where the ZB# was posted for the 1M DSC.

@Stokes Please report if you're successful in getting the 1M DSC bin flashed to the non-M/non-1 unit, I haven't had time/energy to try yet. Thanks.
 
  • 1Like
Reactions: aus335iguy

Similar threads


Top